summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorFrederick Yin <fkfd@macaw.me>2020-07-04 22:12:11 +0800
committerFrederick Yin <fkfd@macaw.me>2020-07-04 22:12:11 +0800
commit9527f0b05945871190e1592086e1d48e134dbaa5 (patch)
tree49a4bef40b10d9bf44b19ee3e7c05c885c1d154b /setup.py
parent0be69d4b5db18b1e0794fd3dc3297da0a16b1ccf (diff)
Add or edit site
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 91a284d..c2aecc9 100644
--- a/setup.py
+++ b/setup.py
@@ -13,10 +13,11 @@ except FileExistsError:
with open("README.md", "r") as f:
long_description = f.read()
+ f.close()
setuptools.setup(
name="utab", # Replace with your own username
- version="0.1.0",
+ version="0.2.0",
author="Frederick Yin",
author_email="fkfd@macaw.me",
description="Web browser new tab dashboard HTTP daemon",
@@ -24,6 +25,7 @@ setuptools.setup(
long_description_content_type="text/markdown",
url="https://git.sr.ht/~fkfd/utab",
packages=setuptools.find_packages(),
+ install_requires=["flask>=1.1.2", "beautifulsoup4>=4.3.2", "requests>=2.1.0"],
classifiers=[
"Programming Language :: Python :: 3",
"License :: OSI Approved :: BSD License",