summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py33
1 files changed, 33 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..91a284d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,33 @@
+import setuptools
+import os, shutil
+from pathlib import Path
+from appdirs import user_data_dir
+
+# copy templates, data storage and default config
+data_dir = user_data_dir("utab")
+try:
+ shutil.copytree("utab/data/", data_dir)
+except FileExistsError:
+ pass # do not overwrite existent data
+
+
+with open("README.md", "r") as f:
+ long_description = f.read()
+
+setuptools.setup(
+ name="utab", # Replace with your own username
+ version="0.1.0",
+ author="Frederick Yin",
+ author_email="fkfd@macaw.me",
+ description="Web browser new tab dashboard HTTP daemon",
+ long_description=long_description,
+ long_description_content_type="text/markdown",
+ url="https://git.sr.ht/~fkfd/utab",
+ packages=setuptools.find_packages(),
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: BSD License",
+ "Operating System :: OS Independent",
+ ],
+ python_requires=">=3.6",
+)